kmplayer outbound connection alert.

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_topic_old
kmplayer outbound connection alert.
Avatar
joel2007
Member
Forum Posts: 35
Member Since:
October 4, 2010
sp_UserOfflineSmall Offline
1
November 29, 2010 - 7:45 pm
sp_Permalink sp_Print

Every time I play a video file. My firewall warns "kmplayer outbound connection alert".
What is it trying to connect to? How do I stop it?

Thank you.

Avatar
Jim Hillier
Admin
Forum Posts: 2492
Member Since:
August 9, 2011
sp_UserOfflineSmall Offline
2
November 29, 2010 - 8:26 pm
sp_Permalink sp_Print

Hi Joel - Which firewall? Which one are you using?

I am almost certain this would be KMPLayer phoning home to check if there is an updated version for you to to download. There will, more than likely, be an option in the Settings/Preferences menu under "Updates" (or something similar) that will allow you to disable that function (if you wish to). Try looking under [b:3cnxchpo]Preferences>General>When Starting[/b:3cnxchpo].

KMPlayer's eula does state that no personal information is being collected or sent, only that which relates to the software; version number, installation date, etc.

HTH
Cheers.....Jim

Avatar
joel2007
Member
Forum Posts: 35
Member Since:
October 4, 2010
sp_UserOfflineSmall Offline
3
November 29, 2010 - 9:26 pm
sp_Permalink sp_Print

I use Vipre antivirus firewall. I don't think it checks for update version.
Because when I click on the kmplayer.exe, the firewall doesn't warn. The firewall alerts Only when I click on the movie file and choose to play with kmplayer.

Hi Joel - Which firewall? Which one are you using?

I am almost certain this would be KMPLayer phoning home to check if there is an updated version for you to to download. There will, more than likely, be an option in the Settings/Preferences menu under "Updates" (or something similar) that will allow you to disable that function (if you wish to). Try looking under [b:2bj8h76q]Preferences>General>When Starting[/b:2bj8h76q].

KMPlayer's eula does state that no personal information is being collected or sent, only that which relates to the software; version number, installation date, etc.

HTH
Cheers.....Jim[/quote:2bj8h76q]

Avatar
Jim Hillier
Admin
Forum Posts: 2492
Member Since:
August 9, 2011
sp_UserOfflineSmall Offline
4
November 29, 2010 - 9:40 pm
sp_Permalink sp_Print

OK Joel. I have never actually used KMPlayer myself. Will wait and see if any others with more experience of the player respond. If not I'll download/install KMPlayer and see for myself.

Get back to you mate,
Cheers....Jim

Avatar
Flying Dutchman
Member
Forum Posts: 278
Member Since:
September 2, 2010
sp_UserOfflineSmall Offline
5
November 30, 2010 - 5:01 pm
sp_Permalink sp_Print

Hi Joel,

Jim's right about KMPlayer's outbound connections; it is calling home (61.111.8.245--->www.kmplayer.com) to check for an update. You're getting this because you most likely have "Check if new version is available" enabled.

If you want to disable this, you need to do the following:
Open KMPlayer. Righ click on it and go to Options>Preferences. In that screen, go to the tab "When Starting" on the right side of that screen (it's the second one). Look for the option "Check if new version is available" and uncheck it.
Now, play your video and see if you're getting an alert - you shouldn't; if you're still getting one, then there has to be something fishy with your video.

The reason you get the alert only when you start a video (or audio) is because KMPlayer does not actually/ actively start unless you give it something to play.

I am human

Avatar
Chad Johnson
Mod
Forum Posts: 867
Member Since:
August 11, 2011
sp_UserOfflineSmall Offline
6
November 30, 2010 - 8:11 pm
sp_Permalink sp_Print

Could it be trying to download video information, licensing, or DRM stuff? I don't know much about kmplayer either, but I may go download it to see.

Avatar
joel2007
Member
Forum Posts: 35
Member Since:
October 4, 2010
sp_UserOfflineSmall Offline
7
December 3, 2010 - 1:18 am
sp_Permalink sp_Print

Hi Joel,

Jim's right about KMPlayer's outbound connections; it is calling home (61.111.8.245--->www.kmplayer.com) to check for an update. You're getting this because you most likely have "Check if new version is available" enabled.

If you want to disable this, you need to do the following:
Open KMPlayer. Righ click on it and go to Options>Preferences. In that screen, go to the tab "When Starting" on the right side of that screen (it's the second one). Look for the option [color=#0040FF:30ciuost]"Check if new version is available" and uncheck it.[/color:30ciuost]
Now, play your video and see if you're getting an alert - you shouldn't; if you're still getting one, then there has to be something fishy with your video.

The reason you get the alert only when you start a video (or audio) is because KMPlayer does not actually/ actively start unless you give it something to play.[/quote:30ciuost]

I already have it unchecked. I'm still getting the alert when I play video files.

Avatar
Flying Dutchman
Member
Forum Posts: 278
Member Since:
September 2, 2010
sp_UserOfflineSmall Offline
8
December 3, 2010 - 6:19 pm
sp_Permalink sp_Print

Hi Joel,

Since you have updates unchecked, I'd say it has something to do with your videos; either one of the things Ziggie suggested or something less ok, like spyware.

I'm not familiar with Vipre Firewall, so can't go into much detail here, but you could check the network rules and the firewall log which could help you see where these connections are made to, i.e. their IPs which you could then look up and see how innocent or bad things are.

I don't know how experienced you are with this kind of software, but another approach would be to get LayerView ([url=http://www.davescomputertips.com/forum/viewtopic.php?f=30&t=1122:1led0c0f]LayerView (packet sniffer software) FREE!![/url:1led0c0f]) and run it while you're playing your videos. It'll give you detailed information.

I'm afraid that's all the help I can offer you.

I am human

Avatar
joel2007
Member
Forum Posts: 35
Member Since:
October 4, 2010
sp_UserOfflineSmall Offline
9
December 7, 2010 - 3:18 am
sp_Permalink sp_Print

Here is the firewall log:
[img:1ca241gi]http://img442.imageshack.us/img442/5479/kmplayer0.png[/img:1ca241gi]

Direct Link:
http://img442.imageshack.us/im.....layer0.png

Avatar
Chad Johnson
Mod
Forum Posts: 867
Member Since:
August 11, 2011
sp_UserOfflineSmall Offline
10
December 7, 2010 - 2:39 pm
sp_Permalink sp_Print

IP address 61.111.9.180 is registered to Korea.

I think there is some malware going on.

Have you done the standard malware / spyware scans??

Avatar
Jim Hillier
Admin
Forum Posts: 2492
Member Since:
August 9, 2011
sp_UserOfflineSmall Offline
11
December 7, 2010 - 8:16 pm
sp_Permalink sp_Print

Ziggie - KMPlayer[i:24sav1ct][b:24sav1ct] is[/b:24sav1ct][/i:24sav1ct] Korean.

Avatar
Chad Johnson
Mod
Forum Posts: 867
Member Since:
August 11, 2011
sp_UserOfflineSmall Offline
12
December 8, 2010 - 11:00 am
sp_Permalink sp_Print

Hm.

I stand corrected.

Though the main kmplayer is found at 194.116.241.53, which is out of Spain.

Hence my confusion.

Avatar
Jim Hillier
Admin
Forum Posts: 2492
Member Since:
August 9, 2011
sp_UserOfflineSmall Offline
13
December 8, 2010 - 6:31 pm
sp_Permalink sp_Print

You are quite right Zig. In fact pretty much all the sites connected with KMPlayer do not lead to a Korean address. It is confusing!!

I just happened to know that KMPLayer comes out of Korea.

Avatar
Chad Johnson
Mod
Forum Posts: 867
Member Since:
August 11, 2011
sp_UserOfflineSmall Offline
14
December 8, 2010 - 10:01 pm
sp_Permalink sp_Print

According to this post (originally in Spanish, but this is the Google translated link):
[url=http://translate.google.com/translate?hl=en&sl=es&u=http://www.kmplayer.com/forums/showthread.php%3Fp%3D82096&ei=wEQATefVF8SpngeE7pzlDQ&sa=X&oi=translate&ct=result&resnum=1&sqi=2&ved=0CBsQ7gEwAA&prev=/search%3Fq%3Dkmplayer%2Bcalling%2B61.111.9.180%26hl%3Den%26prmd%3Div:24b51u9j]Google translated page[/url:24b51u9j] this is a known bug. I would imagine it's fixed in the next version.

--Zig

Avatar
joel2007
Member
Forum Posts: 35
Member Since:
October 4, 2010
sp_UserOfflineSmall Offline
15
December 10, 2010 - 12:23 am
sp_Permalink sp_Print

Should I block the outbound for now until the next version fix? Does it happen to anyone else or just me?

Forum Timezone: America/Indiana/Indianapolis

Most Users Ever Online: 188

Currently Online:
14 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Member Stats:

Guest Posters: 10

Members: 1272

Moderators: 3

Admins: 4

Forum Stats:

Groups: 8

Forums: 19

Topics: 1538

Posts: 11824

Administrators: Jim Hillier, Richard Pedersen, David Hartsock, Marc Thomas

Moderators: Judy Novotny, Jason Shuffield, Mail Poet