Downloading and installing Firefox 3.1

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_topic_old
Downloading and installing Firefox 3.1
Avatar
mesmd
Member
Forum Posts: 15
Member Since:
September 17, 2008
sp_UserOfflineSmall Offline
1
October 5, 2008 - 5:35 am
sp_Permalink sp_Print

Hi,
I am a super Novice. I have been using FF 2.0.017, but wanted to try the new version of FF 3.01. Can I just download and install FF 3.01 without uninstalling my FF 2.0.017? Or will that mess up my both versions of FF? I would like to have both versions installed and working independently. I believe that FF 3.01 will not run many of the add ons, plug ins, etc. , that FF 2.x uses. I really only want the "Mail Icon to open my Thunderbird Email.

Thanks for any help or suggestions; I heard FF3.1 is a much faster Browser than FF2.x?

Miles

Avatar
David Hartsock
Admin
Forum Posts: 1105
Member Since:
August 7, 2011
sp_UserOfflineSmall Offline
2
October 5, 2008 - 8:10 am
sp_Permalink sp_Print

Miles, Welcome to the forum and thanks for posting your question!

Firefox 3 has many benefits over version 2. It's faster, uses less memory, better password management (still not as good as Roboform!), updated download manager , etc. The coolest new feature is the address bar (in my opinion). When you begin typing in the address bar it looks your bookmarks and history. If you've visited a site or stored a bookmark it brings up those matching sites as you type. It also "learns", so sites you visit more often appear first. It's very useful.

Some of the addins may be a problem because the underlying framework is a little different, but I don't think that is a big problem. Open up your addin manager and write down the extensions you have that you really use. Go to [url:8syrh26h]https://addons.mozilla.org/en-US/firefox/[/url:8syrh26h] and see if they are compatible with version 3.

To be honest, every extension I use except one was updated. FF3 will install over FF2 and automatically check the compatibility of the addins already installed. If they aren't compatible it will disable them and notify you. This is the path I would follow. FF2 won't be supported much longer, so go ahead and update. It's a better browser and you won't be sorry.

Avatar
Mindblower
Montreal, Canada
Member
Forum Posts: 411
Member Since:
September 17, 2008
sp_UserOfflineSmall Offline
3
October 5, 2008 - 8:13 am
sp_Permalink sp_Print

I've been upgrading FF ever since version 1.? without any major set backs. Why not simply revist the addons and see if they've been upgraded to work with the latest version. If not, it's generally a short time before they are, since there are many like me who do upgrade the program for security, Mindblower!

PS See that while I was posting (the BOSS) was also, and beat me, Mindblower!

"Light travels faster than sound;
That is why some people seem bright until you hear them speak"

Forum Timezone: America/Indiana/Indianapolis

Most Users Ever Online: 188

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Member Stats:

Guest Posters: 10

Members: 1272

Moderators: 3

Admins: 4

Forum Stats:

Groups: 8

Forums: 19

Topics: 1538

Posts: 11824

Administrators: Jim Hillier, Richard Pedersen, David Hartsock, Marc Thomas

Moderators: Judy Novotny, Jason Shuffield, Mail Poet