DVD Installation Media

This forum requires Javascript to be enabled for posting content

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
DVD Installation Media
Jim Hillier
Admin
Forum Posts: 2589
Member Since:
August 9, 2011
Offline
1
November 15, 2014 - 4:45 pm

Hi Tom, and welcome to the DCT Forum.

The fact that neither your wireless nor wired mouse and keyboard are recognized is a tad unusual. Is it a UEFI machine or an older BIOS machine? Are you certain the mouse and/or keyboard are plugged into USB 2.0 ports and not USB 3.0?

Cheers... Jim

Jim Hillier
Admin
Forum Posts: 2589
Member Since:
August 9, 2011
Offline
2
November 16, 2014 - 4:53 pm

According to the SIW report, USB 3.0 ports are included with the motherboard. USB 3.0 ports are usually blue, have a look at the back and front USB ports and see if there are any that are blue. Then, make sure the mouse and keyboard are NOT plugged into the blue ports.

Also; are both the Microsoft mouse and keyboard driver and the Microsoft Mouse and Keyboard Center software up-to-date?

You may also need to go into BIOS and see what settings there are relating to USB, mouse, and keyboard.

Jim Hillier
Admin
Forum Posts: 2589
Member Since:
August 9, 2011
Offline
3
November 18, 2014 - 5:34 pm

These settings in BIOS (XHCI and EHCI) are designed to overcome an operating system's shortcomings regarding USB support and management.

For example: XHCI (Extensible Host Controller Interface) is Intel's USB 3.0 controller (driver). The controller was introduced by Intel for USB 3.0 enabled machines running operating systems without native USB 3.0 support (which includes Windows 7). Native USB 3.0 support was introduced in Windows 8.

Not sure if these settings have anything to do with the issue or not but, considering a fresh install means you are working outside of an existing OS and relying solely on BIOS, it may well be the case.

I would try changing those settings in BIOS to see if they make any difference. First; try setting EHCI Hand-off to Enabled. If that doesn't work, try setting both to Disabled.

Let us know how you get on.

Forum Timezone: America/Indiana/Indianapolis

Most Users Ever Online: 2303

Currently Online:
30 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Member Stats:

Guest Posters: 10

Members: 2532

Moderators: 7

Admins: 4

Forum Stats:

Groups: 8

Forums: 19

Topics: 1823

Posts: 13046

Administrators: Jim Hillier, Richard Pedersen, David Hartsock, Marc Thomas

Moderators: Carol Bratt, dandl, Jason Shuffield, Jim Canfield, Terry Hollett, Dick Evans, Sergey Grankin

Exit mobile version

WHY NOT SUBSCRIBE TO OUR NEWSLETTER?

Get great content like this delivered to your inbox!

It's free, convenient, and delivered right to your inbox! We do not spam and we will not share your address. Period!