problem with printing functionaliy with ubuntu/VMWare workstation

This forum requires Javascript to be enabled for posting content

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
problem with printing functionaliy with ubuntu/VMWare workstation
Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
1
March 10, 2016 - 9:41 am

Hello,

I´ve got a problem regarding printing in ubuntu.
Perhaps there´s someone who can help.

Info: Ubuntu 14.04.4 LTS 32bit
Kernel 3.16.0-62-generic
ubuntu is running as a VM in: VMware® Workstation 12 Player
12.1.0 build-3272444

Host: WIN8.1 update (64bit)

Host is running PDF-Creator (version 6.9.2 by geek-software (www.pdf24.org).
-------------------------------------------------------------------------------

Up to a recent point in time I easily could do the following:

When using ubuntu as a virtual machine I was able to select any picture-file or even a web-page (using firefox) and then print it out as a pdf-file.
The respective file was passed through by the guest-system to the host-system and was then "printed out" by PDF-Creator.

This is the exact procedure that doesn´t work any more. I suppose this is due to the update of my Workstation 12 Player, but I´m by no means really sure of that.

I looked up PRINTER PROPERTIES in ubuntu and PRINTER STATUS was "inactive" or "idle" or something like that.
The original message is: "Druckereigenschaften, Druckerstatus: untätig" (as my system has German language output).

I have no idea why that is.
Any ideas are welcome.

Greetings
Rosika

Attachments
dandl
Lexa, AR
Moderator
Forum Posts: 708
Member Since:
April 29, 2013
Offline
2
March 10, 2016 - 10:13 am

My first thought is that if you updated your VMware Player did you reinstall the VMware Tools?

Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
3
March 10, 2016 - 10:27 am

Hi Daniel,

so nice to hear from you again.
And thanks for your fast reply.

To answer your question: Yes, I did.
And furthermore - to add to the awkwardness of the situation - let me tell you this:

I have WIN 10 running as a second virtual machine - also in VMWare workstation.
And yet there´s not the aforementioned problem.
I´m perfectly able to print anything originating in WIN 10 (guest) by using my PDF-printer in the host.
So it´s just ubuntu which makes difficulties.

Nevertheless I suspected the new VMWare-version due to the fact that I couldn´t encounter those difficulties before the update.

Anyway thanks for your comment.

Greetings
Rosika

dandl
Lexa, AR
Moderator
Forum Posts: 708
Member Since:
April 29, 2013
Offline
4
March 10, 2016 - 11:14 am

From what I read Ubuntu has support for Print To File to print a pdf document into your home folder but this option is not available with all print jobs. I have a couple of links that you might want to read.
http://askubuntu.com/questions/81817/how-to-install-a-pdf-printer
https://help.ubuntu.com/lts/serverguide/cups.html
Hope this helps. Getting printing to work in Linux can be a challenge at times.

Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
5
March 10, 2016 - 12:36 pm

Hi Daniel,

Ubuntu has support for Print To File to print a pdf document into your home folder

Yes, that´s correct. I´ve tried that already and it works.

As far as my problem is concerned I have to say it bothers me because not being able
to "print" a PDF-file with PDF-Creator in my host is just an example.

Neither can I print with my physical HP-printer because n o t h i n g is passed through
to the host.

As I´ve already said: "I looked up PRINTER PROPERTIES in ubuntu and PRINTER STATUS was "inactive" or "idle" or something like that."

I think the problem lies there. And I really don´t know why on earth the printer status is idle.

Nevertheless thanks for the links.

Grretings
Rosika

dandl
Lexa, AR
Moderator
Forum Posts: 708
Member Since:
April 29, 2013
Offline
6
March 10, 2016 - 2:39 pm


This is the printer I use with my Ubuntu 14.04 VM running a W10 host. I had to delete some older printers and rerun a printer search and then add my Canon MX320 and let Ubuntu search for drivers. Is all your output in German?
Attachments
Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
7
March 11, 2016 - 7:17 am

Hi Daniel,

thanks for your post.

Well, I´ve tried that already. I also ran a printer search and thus was looking for network printers. Alas the system couldn´t find any. And that´s the real problem.

In the meantime I deleted my PDF24PDF-printer in ubuntu in order to make a new printer-search more effective (???).
I think I shouldn´t have done that as now the aforementioned PDF-printer is gone and the search for network printers didn´t produce any results.

I believe as long as printer status is idle things won´t get better.

Is all your output in German?

Yes, all my output is in German.That´s the language I chose when installing the system.

Thanks a lot for all the effort of yours.

Greetings
Rosika

Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
8
March 11, 2016 - 8:09 am

Latest update:

Hi Daniel,

Once more I was looking through all the information you´ve given to me and I stumbled over your very first reply:

My first thought is that if you updated your VMware Player did you reinstall the VMware Tools?

At the time I was very sure that I did. But now considering all that I´ve done in the meantime I´m not so sure any more.
To make a long story short - a few moments ago I did just that (once again??).
And NOW: everything works just fine.

My PDF-printer shows up under "printers" and I can use it like I did before.
Reinstalling the VMWare tools did the trick.

I` m so sorry I didn´t do that right at the beginning. Or did I and it just went wrong?
I really couldn´t tell.

Nevertheless thank you so much for your help. I am very grateful for all you have done for me.

I wish you a very fine day.
Greetings

Rosika

Attachments
dandl
Lexa, AR
Moderator
Forum Posts: 708
Member Since:
April 29, 2013
Offline
9
March 11, 2016 - 10:11 am

Hi Rosika
I am so glad you found the solution. Did you install the "open-vm-tools-10.0.5-3227872.tar.gz" or the "VMwareTools-10.0.5-3228253.tar.gz?
I installed the generic VMwareTools but I think I should have installed the open source.
Always a pleasure to talk about Linux. Daniel.

Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
10
March 11, 2016 - 10:51 am

Hi Daniel,

I installed "VMwareTools-10.0.5-3228253.tar.gz".
And it worked just fine. Actually I always install the "VMware[...]-version" and I haven´t encountered any difficulties. (Unless I forget to install them ..... )

For me it´s a pleasure to talk about Linux as well, especially in view of the fact that there´s no one around in my circle of friends and acquaintances who has the slightest interest in switching to a linux distro or even trying it out as a VM.

The prevailing opinion is that a computer is a thing to be used with nothing to worry about. It´s an apparatus that should work on its own and nobody is interested in the care of computers.
Try talking about Linux to people with that kind of attitude .......

So thanks again for all your help and have a nice weekend.

Rosika

dandl
Lexa, AR
Moderator
Forum Posts: 708
Member Since:
April 29, 2013
Offline
11
March 13, 2016 - 9:13 am

Hi Rosika

"The prevailing opinion is that a computer is a thing to be used with nothing to worry about. It´s an apparatus that should work on its own and nobody is interested in the care of computers.
Try talking about Linux to people with that kind of attitude ......."

Been thinking about your comment and just had to respond. One really needs to think out of the box and be willing to try something different when it comes to a PC. I think here in the "USA" people would rather just throw their PC in the garbage, and buy a new one, than explore other PC setup options. Daniel.

Rosika
Member
Forum Posts: 68
Member Since:
November 27, 2014
Offline
12
March 13, 2016 - 9:30 am

Hi Daniel,

thanks for your comment once again.

Like you said, people are just not willing to try out something new. It´s the same here in Germany - at least to my knowledge.

It´s a real shame considering the fact that there´s a great opportunity of experimenting/getting acquainted with an alternative OS by using VirtualBox or VMWare products without having to mess with the setup of one´s physical machine/productive system.
Yet up and until now I couldn´t for the life of me get anyone even to consider it.

Have a nice weekend.

Rosika

Forum Timezone: America/Indiana/Indianapolis

Most Users Ever Online: 2303

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Member Stats:

Guest Posters: 10

Members: 2577

Moderators: 7

Admins: 4

Forum Stats:

Groups: 8

Forums: 19

Topics: 1836

Posts: 13094

Administrators: Jim Hillier, Richard Pedersen, David Hartsock, Marc Thomas

Moderators: Carol Bratt, dandl, Jason Shuffield, Jim Canfield, Terry Hollett, Dick Evans, Sergey Grankin

Exit mobile version

WHY NOT SUBSCRIBE TO OUR NEWSLETTER?

Get great content like this delivered to your inbox!

It's free, convenient, and delivered right to your inbox! We do not spam and we will not share your address. Period!